RPM dependency hell


Now that I've automated the installation of mediawiki on Fedora 9 using puppet, I thought I'd see if I could install the OpenID extension for mediawiki and maybe automate that installation as well.

Unfortunately, the mediawiki-openid extension requires php-openid (OpenID implementation in PHP) which is not to be found in the standard Fedora repositories. However, I have found it in the ATrpms Fedora 9 repository. After adding that one in my yum config it showed that it also contained a mediawiki-openid package. Things were looking up!

However, this is the error I get when trying to install said package:


[[email protected] ~]# yum install mediawiki-openid.noarch
atrpms | 951 B 00:00
fedora | 2.4 kB 00:00
updates | 2.3 kB 00:00
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package mediawiki-openid.noarch 0:0.8.2-7 set to be updated
--> Processing Dependency: php-pear-Auth-OpenID >= 2.0.1 for package: mediawiki-openid
--> Running transaction check
---> Package php-pear-Auth-OpenID.noarch 0:2.0.1-4.fc8_93 set to be updated
--> Processing Dependency: php-pear-DB >= 1.80 for package: php-pear-Auth-OpenID
--> Processing Dependency: php-pear for package: php-pear-Auth-OpenID
--> Processing Dependency: php-pear-Net-Curl for package: php-pear-Auth-OpenID
--> Processing Dependency: php-bcmath for package: php-pear-Auth-OpenID
--> Processing Dependency: php-pear(PEAR) for package: php-pear-Auth-OpenID
--> Running transaction check
---> Package php-pear-Auth-OpenID.noarch 0:2.0.1-4.fc8_93 set to be updated
--> Processing Dependency: php-pear-DB >= 1.80 for package: php-pear-Auth-OpenID
---> Package php-pear.noarch 1:1.7.1-2.fc9 set to be updated
---> Package php-bcmath.i386 0:5.2.6-2.fc9 set to be updated
---> Package php-pear-Net-Curl.noarch 0:1.2.5-1.fc9 set to be updated
--> Finished Dependency Resolution
php-pear-Auth-OpenID-2.0.1-4.fc8_93.noarch from atrpms has depsolving problems
--> Missing Dependency: php-pear-DB >= 1.80 is needed by package php-pear-Auth-OpenID-2.0.1-4.fc8_93.noarch (atrpms)
Error: Missing Dependency: php-pear-DB >= 1.80 is needed by package php-pear-Auth-OpenID-2.0.1-4.fc8_93.noarch (atrpms)
[[email protected] ~]#


That's right: broken dependencies. I guess I should have expected this since I'm using a 3rd party repository, but even then I wonder why the php-openid package isn't packaged by Fedora by default ? After all, it comes from the same website as python-openid and ruby-openid, both of which are in the standard Fedora 9 repositories...